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MIDI SETUP

The MIDI setup window (Control+M or Command+M) can be found under the MIDI window menu. In the
MIDI Setup window, select the MIDI IN and OUT ports to which the OB-X8 is connected and set the MIDI
Channel to match the MIDI channel on the OB-X8.

Once the proper ports and MIDI channel are selected, you should see the current OB-X8 software version at
the top of the MIDI Setup window as shown.

This confirms that SoundEditor is communicating with the OB-X8.

To establish a proper MIDI communication. Make sure that the Global Parameters are set MANUALLY (not
through the computer) on OB-X8 as follows.

To control the OB-X8 in real-time:

MIDI Channel: ALL

Param Xmit: NRPN (nr)

Param Rcv: NRPN (nr)

MIDI Control: On

For data communication:

MIDI Sysex: USB (Usb) or MIDI (Nid) - depending on your connection

MIDI Out: USB (Usb) or MIDI (Nid) - depending on your connection

Please refer to https://youtu.be/Kix08-8nwvs (Oberheim OB-X8 Global Settings and MIDI Setup for
Soundtower Editor) for more information.

Also, please make sure that the Editor and the OB-X8 have the same MIDI channel or OB-X8 MIDI channel is
set to ALL.

GLOBAL SETTINGS

The OB-X8 Globals (Control+G or Command+G) can also be found under the MIDI window menu.
Please note that some settings that are necessary for maintaining a proper MIDI communication
are disabled and cannot be changed directly for the editor.

MIDI WINDOW MENU

Here you can access all functions that will enable the editor to communicate with the OB-X8 and sync the data
by receiving all banks.

In the MIDI Setup you can configure which MIDI ports should be used to communicate with OB-X8.

Global Settings panel lets you view all OB-X8 Globals.

Important. Changes made by the editor are not saved automatically on OB-X8.

To write global settings changes you need to enter and exit Globals mode directly on the OB-X8 panel.

https://youtu.be/Kix08-8nwvs


Front Panel

Let’s review the various buttons and sliders on the front panel.

The upper left buttons allows you to switch between Voice and Banks view

The Midi and Global buttons open windows previously discussed in the manual.

The Split and Double buttons will be discussed below.

The slider at the bottom of the window may be clicked or dragged to show various areas of the editing panel.

The Horizontal/Vertical button determines the orientation of the panel to accommodate available monitor space.

The percentage button likewise adjusts the magnification to accommodate available monitor space.

Stack Modes

The OB-X8 offers two “Stack” modes - Split or Double. Split allows the keyboard to be divided into two regions
and play a different program in each region or Double mode where two different programs can be played at the
same time over the entire keyboard.

When either Split or Double modes are selected, the first window that appears shows the parameters common
to both halves of the stack.

For this example we will show Split mode. Double mode works the same way.

On the top of the panel there is now shown Normal, Split and Double buttons to navigate between modes and
Lower and Upper voices to focus the individual program that makes up the Split or Double.

The items available in the program File, Edit and Midi menus will reflect the selected mode.

When you open a Split or Double, the coinciding Bank is opened on the left side to allow access to currently
available programs.

Split and Split+ (Double and Double+)

The normal and “+” Stack Programs differ in one key manner:

Normal Split or Double programs select the two individual programs that make up the stack by program location.
These selections are references only, meaning that if you have a Stack program that uses the first and second
programs from any bank, should you ever edit or replace either or both of those single programs, the Stack
program will not recall correctly because the source programs have been modified.

The “+” option for Splits and Doubles actually save all the data for each of the two programs as part of the
Stack program. When a “+” Stack Program is saved, changing the individual normal programs that make up that
stack program will not affect the saved stack.

This is by far the safer way to save Stacks.

Be sure to consider and understand these two options before making changes to individual normal (single)
programs.

Clicking Upper or Lower will bring up the full front panel display. From here you can make edits to the individual
programs as needed.

When this view is open, there are additional buttons to modify the panel layouts to best match your available
monitor configuration. View reverses the order of upper and lower voices and Horizontal/Vertical changes the
orientation of the two panels and the % slider will zoom in and out. An additional slider on the right side will
allow you to scroll as needed to see the two panels.

You will need to save any changes that are made to edited single programs using the Write button on the front
panel or programs, or the Save option in the File menu. Please note - the option to save the upper or lower
voice from the File menu will depend on which voice is active.

This window will appear where you can determine where you would like to save the edited program.

Again, please remember, saving in this manner will possibly effect other Stack programs that use the original
version of the modified program.



BANK PANEL VIEW

The Banks Panel lets you see all User and Factory program banks where you can select Programs for editing or
audition.

Here you can copy and paste programs between the banks or move programs around by dragging them to new
locations.

You can swap locations of any two programs by dragging if you wish to reorganize programs on this page.

A more efficient way to create custom banks is in the Librarian discussed later in the manual.

When you right-click on a selected program you will be presented with the pop-up menu.

In the Bank View you can copy and paste only one program at a time. To copy and paste multiple programs use
the Program Bank Manager / Librarian window.

Pasted, renamed, loaded and initialized programs will be automatically written to the OB-X8 at the selected
Bank/Program location.

If you like to load saved single programs only to the edit buffer only, then use the Load Single Program
function located under the window File menu.

If you wish to view available programs based on Categories, click the Category button and you will see the
following screen.

Simply click the bank or category button to view the programs that are included in that collection.

SEARCH TOOL

The SEARCH button (Control+F) brings up the Program Search where you can search for programs in all OB-X8
banks.



Menus

Clicking on the OB-X8 Editor menu and under Settings you can set how the mouse wheel adjustment will
function and how the mouse and knob value adjustments function.

When you click on Load Program To and select a bank, you will be presented with a dialog screen where you can
select a previously saved bank. When you select a file, you will be presented with the Bank Loader screen.

Click on the button on the left to confirm the correct bank will be loaded then select the desired bank under the
Load to: list.  A SEND button will appear . When you click, a dialog will appear to confirm.

A window will appear allowing you to Start the transfer.

When finished, click Done.

The MIDI menu shows items that have been previously described in this manual (Midi Setup and Global
Settings.)

From this menu you can also receive or transmit current banks from the OB-X8.

Items in this menu will change depending on which mode you are in - (Normal, Split or Double).

PLEASE NOTE!!!

If you have done any editing of programs on the OB-X8 and saved them, it’s recommended that you receive all
program banks as needed to synchronize the synth and the editor.

The Mode menu allows you to select either of the Stack modes and select between the upper or lower
voice.

The Parameters allows you to bring into focus the various sections of the editor.

This can be very helpful when using smaller monitors. Keyboard shortcuts are shown for your convenience.

Snapshots is another quick and convenient way to quickly save the current program. This could
be very useful while making edits on a program and you wish to save and be able to recall
incremental changes during the process. Snapshots will be saved with the editor and be
available on restart.

Sound Generators will be featured in another section of the manual.

The Edit menu offers the same functions that are offered by right clicking on a Program Name in the Banks
window. The keyboard shortcuts are shown if you prefer.

File menu

Some of the items available will change depending on what mode the synth is currently in (Normal, Split or
Double) however the functions are similar.

There are a number of  options to Save or Load instrument data in various formats depending upon your needs.

Loading a single program from disk will load the program into the synth’s edit buffer and will not be
automatically saved.

At the bottom of the File menu list are features of the editor that can be focused by selecting in the menu or
using the shown keyboard shortcuts.

PLEASE NOTE!!

It’s recommended that you execute a full Save All OB-X8 Data to be sure you have a file of the current status
of your synth. You can always load this file back to the OB-X8 if needed.

Options provides a virtual onscreen keyboard and the X-Y pad allows you to select various parameters
and adjust them using the click and drag virtual pad.

The View menu lets you orient the editing screen to best suit available space on your monitor



The Librarian feature of the OB-X8 Editor/Librarian is a tool to organize, save and share all the programs, splits and doubles
you can possibly create.

This feature can be opened from the File menu or by clicking the Librarian button on the Banks page.

You will be presented with this page…

(Shown is the single voice Librarian. Splits and Double Librarian have slightly different options described below…)

Across the top of the page, these buttons will…

Load - import a saved bank from disk into the librarian.

Save - save the current bank to disk.

Receive - receive the current bank on the OB-X8 to the current bank selected in the Librarian.

Transmit - send the current bank to the synth.

Edit - return to the front panel editing screen.

Add current program - transfer the current program on the synth to the librarian.

The remaining buttons on the top row will be described in the next section.

 Above the Bank window are buttons to select the available banks.

The Bank window shows the name and category of the available programs.

The Right facing arrow transfers the selected programs over to the gathering area.

The Left facing arrow transfers programs selected on the right side back to the bank list and to the synth.

Notice that the transferred programs have been organized into individual banks based on category,

Highlighted in this example is 41 Synth programs.

Let’s look at the top row of buttons that now come into play.

New - create a new empty gathering area on the right side of the screen.

Load - import a saved back to the right side of the librarian.

Save - save a bank on the right side of the librarian to disk

Transmit - send the programs in the list on the right.

New - create a new empty gathering area on the right side of the screen

Load - import a saved back to the right side of the librarian

Save - save a bank on the right side of the librarian to disk

Transmit - send the programs in the list on the right to the synth.

Clicking the Auto Audition button will allow you to click on any program on the right side and the program will load into
the OB-X8 edit buffer so you can audition the sound. This doesn’t overwrite any program on the synth.

By selecting any number of programs in the visible collection in the right hand list and clicking the left facing arrow will
send the programs in the list on the right to the synth, starting at the selected program on the left side and overwriting
the needed program slots below to complete the transfer.

After selecting programs from the Bank window, they can be sent to the right side of the librarian to be organized.

Multiple programs can be transferred in a single move.

Contiguous programs can be selected by clicking on the first desired program, scrolling to bring the last desired
program into view, hold the shift key and click

Non-contiguous prams can be selected by clicking on programs one at a time while holding the Command (Control)
key.

Once the desired programs are selected, click the right facing arrow.

You have the option to split the programs to be tansfered into separated banks by category (by clicking
OK), to transfer them into a single unassigned file (by clicking NO) or to cancel the transfer

Shown below are the results of clicking OK

The Stacks version of the Librarian (Splits and Doubles) offers some of the same features with a few differences.

Shown is the Splits Librarian.

You can move split or double programs from the left side over to the right as a way of gathering specific collections.

All saving and loading functions are the same.



Phantom Banks Phantom Banks Video

Phantom banks provide an additional storage space for a virtually unlimited number of programs and banks. These
banks and programs will be available at any time.

You can also recall Factory banks from this window if you need to restore a specific program or full bank.

Phantom Bank Menus

File

New Collection - Create a new blank bank to collect programs in. You can rename the bank by double
clicking the title.

Load and Save Collection File - Manage Phantom Bank collections saved to disk.

Load Bank From - You can load previously saved standard OB-X8 bank files into a Phantom Bank.

Export Bank as SysEx file - A Phantom bank can be saved as a sysex file if required.

Edit

Copy and Paste Program - Copy a program in a Phantom bank and Paste to a different location.

Add Current Program  - adds the current program on the OB-X8 to the Phantom Bank

Initialize - Initializes the currently selected Phantom Bank program.

Write Program - Writes the currently selected program to the OB-X8.

Remove Bank - Removes the currently selected bank

Add Initialized Bank - Add a new bank with all initialized program slots.

Midi

Dump to Bank - Transmit the current bank to the OB-X8. This will overwrite the selected bank in the
synth.

https://www.youtube.com/watch?v=UZHxJ7VjGIQ


PROGRAM MORPHER

Similarly to the Morph function in the Program Genetic, patches are created by linearly interpolate parameters from a
selected program from the list on the left to a selected programs from the list on the right.

At the center there is the mouse X-Y pad that you can use to dynamically change some additional parameters
allowing to quickly produce more variations.

Whenever you like what you hear and you like to keep it, you can use Add to Lib button, rename it, change category
and the current program will be added to the Librarian.

Use the WRITE button to save it directly to OB-X8 banks.

Program Genetics

Genetics allows the user to quickly build new sounds from two existing ones in a similar fashion to breeding.
Parameters of each of the two sources (parents) are combined using three different functions to generate a new bank
of resultant sounds (kids). The four functions are:

Mix: each parameter of each child is randomly chosen from either a parameter from the mother or father source. For
example if the mother’s cutoff frequency was 10 and the father’s was 88; the children’s  values would only be 10 or
88.

Morph: the value of each parameter is linearly interpolated from one parent to the other. The first child is identical
to the mother, the last child is identical to the father. All others are weighted towards each parent depending on their
placement within the list. The middle child is exactly ½ mother and ½ father.

Mutate: the value of each parameter of each child is randomly chosen from within the range between each parent’s
parameter. For example if the mother’s cutoff frequency was 10 and the father’s was 88; the children’s  values would
be between 10 and 88….50, 25, 88, 70, 63 …etc.

Random: Parent independent patch generation. Parameters are generated by random values in the parameter
minimum and maximum range.

The easiest way to audition the results is to play notes using computer keys and click on each child to hear it. If the
sound is pleasing, simply drag and drop it in a sound bank. Then save the bank. Typically only 5% to 10% of the
children are pleasing however use of genetics is certainly the easiest and fastest way to generate new sounds.
Experimentation by using vastly different parents and similar parents creates nice results. You can also interbreed
children too.

Important: The text names are also morphed thus the strange children’s names. This is normal.

Experimentation using vastly different parents or similar parents creates the most interesting results. You can also
‘interbreed’ the child patches, too. In addition, you can set filters to excluded parameters that will not take a part in
the generation of new offspring. Experiment and have fun
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